안경잡이개발자

728x90
반응형

  특정한 PHP 라이브러리를 설치할 때 다음과 같은 오류를 만날 수 있습니다. 이는 흔히 PHP AWS SDK를 설치하시는 분이 만날 수 있는 오류인데요. PHP AWS SDK는 simplexml이라는 이름의 확장 프로그램(Extension)을 사용합니다. 그래서 simplexml이 설치되어 있지 않은 분들은 다음과 같은 오류가 출력되는 것입니다.

 

the requested PHP extension simplexml is missing from your system.

 

 

  이 때는 PHP의 XML 라이브러리를 설치하시면 됩니다.

 

① 최신 버전의 PHP를 사용하는 경우

 

sudo apt install php-xml

 

② PHP 5.6을 사용하는 경우

 

sudo apt install php5.6-xml

 

 

  이후에 다시 라이브러리를 설치하고, Apache 웹 서버를 재시작 해주면 오류 없이 동작합니다.

728x90
반응형

Comment +0